DIDACTIC MICROCOMPUTER ZD537
Instruction for laboratory exercises

Kazimierz Kapłon
Jacek Majewski
Jarosław Sugier

Part I:  Hardware description
Part II:  Program description
Appendix:  1. ZD537 Monitor
          2. Test program
          3. Didactic program
          4. Boards descriptions

Institute of Computer Engineering, Control and Robotics
Wrocław University of Technology, 2003
PART I HARDWARE DESCRIPTION

1. Short description of ZD537 didactic set

ZD537 didactic set is dedicated to laboratory exercises focused on:
- architecture of simple 8-bit microcomputer systems,
- assembler programming of ’51-family microcontrollers,
- rules of ’51-family microcontrollers using.

ZD537 set includes:
- main board with Infineon / Siemens 80C537 microcomputer,
- additional board with: LEDs, keys, buzzers, rectangle signal generator, power stabilizer,
- 16-key keyboard,
- cables to connect ZD537 to PC computer via serial port,
- power supplier without stabilizing elements (7 – 9) V.

Diagrams of main board, additional board and keyboard are available in Appendix 4 – pp. 20 – 21. Diagrams of boards with connectors are presented at page 19.

2. ZD537 main board

Main board includes:
- 80C537 microcomputer, µC 80C537 (U1) chip is enhanced version of µC 8051. 80C537 microcomputer combines:
  - 9 parallel I/O ports: P0 .. P8,
  - 2 serial ports SIO0 and SIO1,
  - 8-bit A/D converter,
  - timers: T0, T1 and T2.

Full description of all modules µC ‘537 modules can be find in [6] and [7].
- ROM memory (27512 chip, U3, [9])
  - includes main ZD537 MONITOR program prepared using KEIL software (see Appendix 1)
- RAM memory (431000 chip, U4, [8])
  - stores user program transmitted by serial port, when the power is switched off RAM memory is lifted by lithium battery available at main board.
Serial ports SIO0 and SIO1 connectors:
- Serial ports SIO0 and SIO1 of μC ‘537 are connected to DB9 connector by voltage converter chip MAX 232 (U9, [13]) – transmission according to RS232. SIO0/SIO1 selection is realised by switch located near DB9 connector. SIO1 transmission can be done also according to RS485. It is necessary to set U10 chip ([15]) and to remove Z10 strap. Transmission according to RS485 over 10m (≤ 1200m) requires special terminators.

RTC (Real Time Clock) - timer/calendar chip (RTC-72421, U7, [11])
- RTC registers are available in XRAM at FF0xh addresses (Fig. 1). RTC is lifted by lithium battery.

Chip MAX691 (U8, [12]) – power guard, RESET signal generation, battery lifting switching.

SW2 switch: system RESET.

LCD module
- 2 lines, 16 character in each line,
- LCD display fixed to main board and connected by LCD1 connector,
- LCD driver’s registers available in XRAM at FF2xh addresses (Fig.1, HD44780 chip driver description – [10]).

Matrix 16-key keyboard
- connected by JP1 connector
- available by scanning method
- keyboard interruptions available with additional chip U11.

8-switch module SW1
- available via P7 parallel port
  Caution: P7 parallel port is also used for keyboard, so when keyboard is in use set SW1 switches to OFF!

Additional elements of main board available via P6 parallel port:
- P6.4 – piezoelectricity converter with 1 kHz generator
- P6.0 – red LED (D3)
- P6.6 – relay’s connectors available at ZS11, ZS12 connectors


A/D converter (8 channels)
- can be driven by SW1 connectors (0V or 5V), continuous changes from 0V to 5V is available if potentiometers are connected to JP10.
GAL chips (U5, U6, type: 16V8) decoders of memory addresses and devices into XRAM

3 modes of main board settings:

a) **MONITOR mode**: Z7=OFF Z8=OFF (upper position of switch) - MONITOR 537 program working;
b) **RAM mode**: Z7=OFF Z8=ON (lower position of switch) - user program working stored in RAM memory;
c) **ROM mode**: Z7=ON Z8=OFF/ON (not important) - program stored in ROM memory working.

- JP5, JP6 connectors – power from additional board supplies main board

3. ZD537 additional board

Additional board is connected to auxiliary power supplier without stabilizing elements (7-9)V. The board includes stabilizer 7805 (IC1). The ZD537 main board is supplied by stabilized power by JP5&JP6 connectors. 8 LEDs are connected using the same connector, they allow to observe lines of P1 parallel port from μC ’537.

The rectangle signal generator (NE555 chip) is connected to line P1.7. Available frequencies are from 1 Hz to 30 Hz. The signal generated by NE555 we can disconnect by taking off J1 strap. R16 resistor is a guard of simultaneous generation by NE555 and μC ’537.

Four lines of P3 parallel port (P3.2, P3.3, P3.4 i P3.5) are supported by LEDs and buttons which can be used for signal generation – interrupts generations. Others bits of P3 are used as system signals \( \text{RD, WR} \) and to serve serial port signals: RxD and TxD. This way they are not available for ZD537 user.

Piezoelectric, electro-acoustic converter is connected to line P3.2. The device is prepared to generate acoustic signals by user programs.

4. Keyboard

Matrix keyboard is connected to main board by JP1 connector. The keyboard includes 4 rows by 4 buttons (Appendix 4, p. 21). The keyboard ought to be read by scanning method: it is necessary to set lines (P5.4 – P5.7) of P5 parallel port by logic zero and read bits P7.3 – P7.0.

If chip U11 is present it is possible to execute keyboard interrupts at line P1.4 (auxiliary interrupt of ‘537 processor). When the keyboard is in use SW1 switches have to be OFF!
5. Cables for serial port transmission

Serial ports signals SIO0 and SIO1 are available at JP2 and DB9 connectors (see p. 21). The switch at the back side of the ZD537 allows to choose which port: SIO0 or SIO1 is connected do DB9 and guarantees the communication µC – PC. Red or black point shows SIO0.

6. Map of ZD537 ports

Map of ZD537 ports you can see at Fig. 1.

- P0, P2 and partially P3 (lines P3.6 and P3.7) are the system buses and are not available for users.
- LEDs are connected to P1. Using J1 strap NE555 as rectangle signal generator can be connected to P1.7. If chip U11 is present it is possible to execute keyboard interrupts at line P1.4
- LEDs and buttons are connected to P3.5 ... P3.2. Piezoelectric buzzer is connected to line P3.2.
- P4 are available for the user at JP9/JP11 connector.
- The older part of P5 is connected to the keyboard. The row-driving is realised by younger part of P7. All lines of P7 are connected to DIP SWITCH SW1. When the keyboard is in use SW1 switches have to be OFF!
- P6 drives: red LED D3 (line P6.0) at main board, relay REL1 and PCI-buzzer which generates 1 kHz signal. P6.6 is responsible for direction of RS485 transmission. RS485 lines are combined to SIO1. P6.7 switches the banks of XRAM memory.

CAUTION:
- P6, P7 and P8 – are available as bytes only, are not available by bits,
- P1, P3, P4, P5 – are available as bytes, are available by bits also,
- P7 and P8 – are read-only (A/D converter ports).
ZD537 Didactic Microcomputer

7. XRAM and CODE memories

Memory map is available at Fig. 1.

- User program is set in CODE memory at address 0000h (RAM memory, U4).
- User variables in XRAM have to be located at 8000h, larger data ought to be allocated just after user program.
- MONITOR program uses XRAM from DF00h (RAM memory, U4).
- MONITOR program code is allocated in CODE memory at E000h (ROM memory, U3)
- I/O ports are available in XRAM from FF00h:
  - 16 RTC registers are available at FF00h, data are in BCD code as 4-bit digits – FF00h – units of seconds, FF01h – tens of seconds, etc.([11]).
  - LCD display registers at FF2xh ([10]).

If user program is generated and set to ROM memory all XRAM (64kB) is available for user. User’s variables can be located at 0000h. I/O ports are not transferred. XRAM banks are switched by P6.7. There is no sense to switch the XRAM banks by MONITOR because MONITOR variables are lost.
PART II SOFTWARE DESCRIPTION

8. Communication with PC computer

Collaboration between ZD537 and PC computer is realised by Keil Software GmbH (http://www.keil.com): integrated environment µVision or simple text monitor mon51.exe. The communication is realised by serial port. To start transmission it is necessary to:

a) set DB9 into SIO0 (switch „turned into red or black point”),

b) realize RESET in MONITOR mode (switch Z8 released MONITOR ZD 537 visible at LCD display).

Communication is realised by monitor generated using Keil devices and stored in EPROM (Appendix 1, [14]).

9. µVision 2 environment

µVision software is an Integrated Development Environment (IDE), which offers all devices necessary during program creation for ’51 microcomputer. It is possible in one application: to edit source code, to compile, to link, to send the ready to use program to ZD537. Then it is possible to start the user program: also step-tracking, you can observe the actual data in registers, ports, memory, etc.

There is a limit of 2kB of ready to use code of user program.

INFO ABOUT SOFTWARE

µVision software is a very sophisticated product. There is help option available: Books (use Help → Open Books Window). The most valuable are the following files:

- „Getting Started with µVision2”, file GS51.PDF;
- „Macro Assembler and Utilities”, file A51.PDF.

PDF file are stored in: Keil\C51\HLP\.

Below you can find the steps of simple program creation.
**NEW PROJECT CREATION**

1) Menu: Project → New project...

- Project files have extension: .uv2.
- Make project in new folder (in the dialog box „Create new project” you can create new folders).
- In dialog box Select device for target ‘Target1’ find proper chip (Infineon SAB 80C537).

2) Options for project: Project → Options for target ‘Target1’ (see Fig. 2)

- Label Target: set frequency Xtal 12 MHz.
- Label Output: check if selected filed: Debug information.

**Caution:** it is possible to start program using simulator (without ZD537). If you want to make it choose in label Debug (Fig. 2a): Use Simulator.

- Button Settings (Fig. 2b): Port Com 1 (used in PC computer for communication with ZD537), Baudrate 9600.

**Caution:** if you use SIO0 in your program there are problems with transmission realised by Keil monitor, clear in that case all options Cache in settings at Fig. 2b.

3) Source file creation

- Choose File → New, use extension a51 or asm for assembler files.
- Add your file to project: choose Project → Targets, Groups, Files..., label Groups / Add files, choose Source Group 1, button Add files to group..., choose your source file.

**COMPILER AND LINKER**

- Choose: Project → Build target (F7) or Project → Rebuild all targets.
In case of errors or warnings double-click at line with error/warning description (available in panel: Build) starts edit option of proper source line.

HOW TO START YOUR PROGRAM

- Choose: Debug → Start/stop debug session (Ctrl+F5).

Caution: if you set in project options: Load application at startup, code of your program is transmitted automatically by serial port and debugger prompts by cursor present at the first line of your program (yellow arrow at the left side of the first line of program code). If you do not observe the described situation there are errors. It is necessary to correct your program before next steps.
- Step by step execution:
  
  - Debug → Go (F5)
  - Debug → Step (F11)
  - Debug → Step over (F10)
  - Debug → Run to cursor line (Ctrl+F10)

- Variables watching (defined in IRAM by assembler DATA option): choose View → Watch & call stack window.

- Memory watching: View → Memory window.

- Different parts of memory you can display as follow:
  - B:0xXX - IRAM memory, bit addressing
  - C:0xxxxx - CODE memory
  - D:0xXX - IRAM memory direct addressing
  - I:0xxx - IRAM memory indirect addressing
  - X:0xxxxx - XRAM memory

10. Text monitor MON51.EXE

MON51.EXE is a simple text program to monitor the state of ’51 sets collaborating with PC computers based on Keil protocol.

To start it type:

```bash
mon51.exe 2
```

where parameter 2 defines the number of Com port. The end by F1 key.

The monitor session is presented in Fig. 3. A ‘#’ symbol is a prompt. The first operation: help presents the monitor functions. The instruction: load test01.hex loads the ready to use test program. The file test01.hex (created using μVision environment for example) ought to be stored in the same directory as monitor mon51.exe. The g (go) operation starts the loaded program. The text PROCESS TERMINATED AT is the result of using RESET key when the program runs. The dc (display code) operation shows in byte-mode the actual state of CODE memory, the u (unassemble) operation the same part of memory after disassembling.

The ready to use test program to verify if parts of microcomputer are OK is described in Appendix 2.
Appendix 1: Monitor ZD537

The collaboration with PC computer is driven by the monitor (the main control program) stored in an EPROM memory. The program was generated using set of tools prepared by Keil Enterprise for μVision environment available in directory: \Keil\C51\MON51\.

The monitor generation was realised as follow ([14]):

install.bat 1 DF E0

where parameters: 1 DF E0 means: transfer speed (9600 bps, internal baudrate generator) and the memory page numbers XDATA and CODE which ought to be used by program (see Fig. 4). The file mon51.hex was created with additional instructions to show MONITOR ZD537 message in LCD display and to initialise RED LED (P6.0, on) and BUZZER (P6.4, off).

Fig. 3: Text monitor mon51.exe at work.
Caution: SIO0 channel is already used for communication matters of the monitor, so there is no chance to observe its state in the user’s program. It is possible to generate the monitor program using SIO1 channel (install.bat 3 DF EO) and to connect two cables to PC computer (Com1 and Com2). This way is possible to trace SIO0 channel by SIO1 channel.

Appendix 2: Test program TEST01.HEX

The TEST01.HEX program is prepared to verify the correct work of all ZD537 parts. At the beginning the following text is presented in LCD display:

If we change the position of switch SW1 we observe the change of character presented in LCD display (‘p’ in figure). Two digits are the result of RTC and they show time in seconds. The code of character set by switch SW1 is transmitted by SIO0 channel. SIO1 channel transmits character code incremented by 1. For example: if SIO0 channel transmits character A, SIO1 channel transmits character B. We can test the results by switching SIO channels (proper switch at the back side of microcomputer).

THE FILE TEST01.HEX

```
:0B019D004368616E77685205357310016
:080300300399FDCC2998FPP992B8A
:0B00B0005B63001FB5398FD8F9C2226
:1000160759020450506390FEEF45050FB050B76
:10002600E50B7002050AE50BB4FFFE350AB41FEE13
:10002600E5FA0E40B53FAEF53FAEF8009A0
:1000460043FA1043FA010508E5088406C628
:1000560043FA1075985243D8807582758BF375CC
:10006600BDF32BE759BB275DD990F1EEO20E759
:10007600F990F2C7438F090FF2EE020E7F990F0FEE
:10008600C741F090FF2EE020E7F990F2C740EFFFF
:10009600F90F2EE020E7F990F2C7400F7BFF74
:1000A6007A01799D12016090F017401F090FF0B85
:1000B6007E50B795079F02B020543FA0180035378
:1000C600FEE020B30553FAEF800343FA1030B4055
:1000D600553FAEF800343FA040850F8090FF2EE020E9
:1000E6007F990F2C7480F090FF2EE020E7F9905E
:1000FF002E508F90FF2EE020E7F990F2DD7424
:1001060020F90FF2EE020E7F990FF00540F244F
:10011600209FF2EE020E7F990FF00E0F1
:1001260050F24300F92DF0AF97801F080501FBD
:1001360023D50F9FF58888F88F90A08120728
:1001460035E5804FF1200BE450AF50B2B2054D
:10015600BEB05020050AE50BB4FF1E50AB40FD7
:07016600ECD2B20020BD2241
:01016D008B0C80A0D890EA0B0CA0A0D9E01201B46071
:01017D001E90FF2EE020E7F9AB0C05EE550EA0D43
:01018D002050D14F91201B490FF2DF080D722E5
:0300000000201A852
:00C01A80078F4F60D8FD75810E0201689
:10018B001B01689828A83E02502E722EBFE0249
:0901C40032289828A83E43227C
:00000001FF
```
Additionally, the test program switch on LEDs connected to P1 and P3 ports (ring-counter driven by zero), the buzzer connected to P3.2, generates sound. If we push the key connected to P3.2 the sound ends. The key connected to P3.3 switched off the buzzer. The key connected to P3.4 is responsible for flip-flop.

If SW1 is switched OFF we can test the keyboard. The key pressing generates the special characters in LCD display and send the characters to SIO0 channel.

Appendix 3: Didactic program

This part of the document presents the TEST program for didactic set ZD537. All modules of the example are written in assembler and are prepared based on template.a51 program by KEIL (see directory: \keil62\c51\asm\template.a51). This is strongly recommended style for assembler programs. The program modules show how to operate with serial transfer via SIO0 and SIO1 channels, LCD display and clock/calendar module called RTC.

The presented modules are the basic examples and they are not finished. The student task is to use the example to prepare their programs in the same style. It is very good idea to create the programs as multi modules structures using segments, macros, etc. The laboratory exercises are not only focused on ’51 processors’ set of instructions, but to learn about assembler’s pseudo operations.

Below you can find the modules with comments. The comments are related to numbers of rows and are signed by #nn, where nn – is the row number.
# Test Program

```assembly
$NOMODS1
NAME TEST ; ZDS7 ASM tutorial
$NOLIST
@include <reg517.h>  // C-style include definition file (for example, 80517)
$INCLUDE(reg517.inc) ; asm-style include definition file (for example, 80517)
$INCLUDE(ZD537.inc) ; definition file for ZD537 board
$LIST
EXTRN CODE (putcharSIO0, putcharSIO1, initSIO0, initSIO1) ; SIO functions
EXTRN CODE (putcharLCD, putstrLCD, putctrlLCD, initLCD) ; LCD functions
EXTRN CODE (disp_time ) ; RTC functions

STACK SEGMENT IDATA ; STACK goes into IDATA RAM.
RSEG STACK ; switch to STACK segment.
DS 50 ; reserve your stack space
; 50 bytes in this example.
CSEG AT 0 ; absolute Segment at Address 0
LJMP start ; reset location (jump to start)

PROG SEGMENT CODE
RSEG PROG
USING 0 ; state register_bank used
; for the following program code.
Start: MOV SP,#STACK-1 ; assign stack at beginning
BUZZER_OFF; ; Buzzer 1kHz off
REDLED_ON; ; optional instruction
call initLCD ;
mov A,#HOME2
call putctrlLCD ; put LCD cursor to second line
MOV DPTR,#text
call putstrLCD ; display string
call initSIO0;
call initSIO1;

?C01:
mov A,'#A'
call putcharSIO0 ; SIO0 <-- 'A' (send character)
mov A,'#B'
call putcharSIO1 ; SIO0 <-- 'B' (send character)
inc P1 ; binary counter on P1 LEDs
opl BUZZPiezzo ; make sound on piezzo buzzer
mov A,#HOME ; display time at fist line on LCD
call putctrlLCD
call disp_time
SJMP ?C01 ; while(1);
RET

TEXT SEGMENT CODE
RSEG TEXT
text: DB "ZDS7 test",00 ; text located in CODE memory
END ; END OF main
```

#1 standard '51 processor registers are turned off, program is for '517 processor.
#4 listing of file header (include) is prohibited, knowing of files reg571.h and reg517.inc obligatory!
#5,6 define files can be prepared as for C and as for assembler style
#10-12 definitions of external subprograms in other modules
#14 definition of stack segment, character ? can be used in the name
#19,20 solid segment, the first instruction after RESET operation
#22 moveable segment, after the interrupt vectors
#26... test program, text in LCD display, loop with A and B characters for SIO0 and SIO1 channels, time in LCD display
#53... text segment organised in CODE part
#3,4 bits definition of P1 and P3 ports, bits can be used by following description: P1.0 - bit 0, port 1
#6-43 no bit-entry to P6 port - no macros to drive the devices connected to P6
#41,42 macro-definition written using C standard
#44-48 LCD registers placed in specific addresses of XDATA, the same solution for RTC registers
A module to drive serial transmission via SIO0 and SIO1. The module is not finished: there are no procedures as: `getchar`, `putstring`, `getstring`, etc.
# LCD.A51 Module

```c
"SWMODS1
NAME LCD_CHAR ; LCD display procedures
"NOLIST
#include <reg517.h> // include CPU definition file (for example, 80517)
;INCLUDE(reg517.inc)
"LIST
PUBLIC putcharLCD, putstrLCD, initLCD, putctrlLCD
; LCD registers
----------------------------------
LCDstatus equ 0FF2EH
LCDcontrol equ 0FF2CH
LCDdataWR equ 0FF2DH
LCDdataRD equ 0FF2FH
// LCD control bytes
#define HOME 0x80    // put cursor to second line
#define INITDISP 0x38 // LCD init (8-bit mode)
#define HOM2 0xc0    // put cursor to second line
#define LCDON 0x0e    // LCD on, cursor off, blinking off
#define CLEAR 0x01 // LCD display clear

LCDcntrlWR MACRO x
LOCAL loop
loop:    MOV DPTR,#LCDstatus
MOVX A,@DPTR
JB ACC.7,loop; check if LCD busy
MOV DPTR,#LCDcontrol ; write to LCD control
MOV A, x
MOVX @DPTR,A
ENDM

LCDcharWR MACRO
LOCAL loop1,loop2
loop1:    MOV DPTR,#LCDstatus
MOVX A,@DPTR
JB ACC.7,loop1; check if LCD busy
loop2:    MOV DPTR,#LCDdataWR; write data to LCD
POP ACC
MOVX @DPTR,A
ENDM

init_LCD MACRO
    LCDcntrlWR #INITDISP
    LCDcntrlWR #CLEAR
    LCDcntrlWR #LCDON
ENDM

LCD_CHAR_ROUTINES SEGMENT CODE
    RSEG LCD_CHAR_ROUTINES
; Initialize serial interface
initLCD:
    init_LCD
RET
; This routine outputs a single character to LCD.
; The character is given in A.
putcharLCD:
    LCDcharWR
RET
; This routine outputs a control character to LCD.
; The character is given in A.
putctrlLCD:
    xch A, R2
    LCDcntrlWR R2
    xch A, R2
```

---

16 ZD537 Didactic Microcomputer
A module for LCD shows macro-definition usage. The module is not finished – Polish characters are not available – for example.
A module for RTC: clock/calendar device. It also shows macro-definition usage. The module is not finished: there are no procedures to set time/date and to write time/date to XDATA or IDATA.
Appendix 4: Diagrams

p. 19 – assembling diagram
p. 20 – ZD537 main board logic diagram
p. 21 – additional devices diagrams
References


PDF files:


[9] NMOS 512K (64K x 8) UV EPROM M27512. SGS-THOMSON Microelectronics, file: 27512.PDF.


